It’s time to upgrade that old phone you’ve been using for Google Wallet payments at the local store. Google is now telling Android users that they’ll have to run KitKat to use Wallet’s tap-to-pay feature from April 14th onward. The company prefers…